, Guest!
Already a Member? Login or Register.

Menu



Showcase


Due to the volume of spam happening on our forums, posting is now restricted to verified members only.  If you're not verified, drop us a note with your username.

Home > FlexCMS Support Forum > User Help > General Support Requests > Installation Error - Flexcms 2.5 -Basic

FlexCMS Support Forum


Installation Error - Flexcms 2.5 -Basic
Started January 9, 2008 @ 7:39pm by renwa983
Post Message 
renwa983


Posts: 4
 
Installation Error - Flexcms 2.5 -BasicJanuary 9, 2008 @ 7:39pm
Hello, I'm getting the error below when trying to install Flexcms version 2.5 on my test system:
----start of message
Database Successfully Connected! Running MySQL Version 4.0.27-standard-log



Directories Created: 23

Files Created: 457

You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=225' at line 1
-----end of error message

Can you tell me where this is coming from?

Thanks
 
DCSun
Administrator



Posts: 625
 
January 10, 2008 @ 4:30pm
It seems that your server is having a problem with the DEFAULT CHARSET portion of the MySQL query.

Can you give us some more information about your server, such as operating system, PHP and MySQL versions, etc.


David


FlexCMS v3.2 Has Been Released!
 
renwa983


Posts: 4
 
Installation Error-Flexcms 2.5January 11, 2008 @ 9:30am
Hello,
Based on PHPinfo():
PHP 4.4.7
MySQL - 4.0.27
Linux - 2.6.9-55.0.9.
Apache/1.3.39 (Unix)

Thanks
 
DCSun
Administrator



Posts: 625
 
January 11, 2008 @ 5:39pm
I don't see anything in those specs that would prevent FlexCMS from working there, so we should be able to get it going.

Download this file, unzip, and upload the v2.5.sql file to the directory where you're installing. There should be one there already, unless you've deleted all the files, and if so just replace it. Remove all the write permissions on the file you just uploaded, and run the installer again. Aside from a message it can't write to that file, the rest should work just fine.


David


FlexCMS v3.2 Has Been Released!
 
renwa983


Posts: 4
 
Flex Installation Error - Flexcms 2.5January 11, 2008 @ 7:09pm
Hi,

Thanks for getting me past the last error, but now I'm getting warning errors and the following as below, and since I don't know what to expect, I'm not sure if I'm done:

---error message start below
Database Successfully Connected! Running MySQL Version 4.0.27-standard-log



Directories Created: 23

Files Created:
Warning: fopen(./v2.5.sql) [function.fopen]: failed to open stream: Permission denied (path)/flexcms/install.php on line 552

Warning: fwrite(): supplied argument is not a valid stream resource in (path)/flexcms/install.php on line 553

Warning: fclose(): supplied argument is not a valid stream resource in (path)/flexcms/install.php on line 554

Warning: chmod() [function.chmod]: Operation not permitted in (path)/flexcms/install.php on line 555
457

Table '(table_name).FLcore-Settings' doesn't exist
 

Last Edit: January 11, 2008 @ 7:09pm by renwa983
DCSun
Administrator



Posts: 625
 
January 11, 2008 @ 7:40pm
The fopen/fwrite/fclose/chmod errors aren't a problem, those are just the result of us forcing the new database file in there.

If you were using a database table prefix, that's the cause of your last error. I've updated the zip file to fix that for you, so download that again and replace the one you uploaded earlier, removing the write permissions again. Then run the installer again and you should be fine. You can go ahead and clear out those tables created the first time around, but they also won't hurt anything to stay there.

David


FlexCMS v3.2 Has Been Released!
 

Last Edit: January 11, 2008 @ 7:42pm by DCSun
renwa983


Posts: 4
 
Installation ErrorJanuary 11, 2008 @ 8:33pm
Hi,

That seem to do it, no more errors. This is the test systems that I am loading on, so I'm assuming I will get the same errors when I load it on the system that will contain Flexcms Premium. Since the SQL file will be overwritten when I run the install, should I just wait for the error and then upload the file you provided me, or is there a way for me to input the correct file.

Thank you for all of your assistance.

Colleen
 
DCSun
Administrator



Posts: 625
 
January 11, 2008 @ 9:43pm
Colleen,

If it's the same server or one you presume will have the same charset problem, you can go ahead and upload the v2.5.sql file, removing the write permissions as before (removing the write permissions prevents the installer from overwriting the file you upload with the one it wants to use). Then run the installation package and you'll get the fopen/fwrite/fclose/chmod error, but the rest should go fine.

Also note that if this is the same site you'll be purchasing a license for later, you don't need to re-install. You can upgrade any free level site to standard or professional through the control panel without losing any data or settings.

Glad you got things sorted out. Sorry you ran into so many problems getting it installed.


David


FlexCMS v3.2 Has Been Released!
 

Last Edit: January 11, 2008 @ 10:05pm by DCSun

Post Message 




Try & Buy FeedForAll - Easy to use RSS Feed Creator - great for iTunes users!

MEMBERS




All Contents, Code, Scripts and Technologies Copyright 2003-2009 FlexCMS.
All Rights Reserved. Software License Agreement

Processing Time: 0.08830 seconds.
 
Management Login

Powered By FlexCMS
Powered By FlexCMS