, Guest!
Already a Member? Login or Register.

Menu



Showcase


Due to the volume of spam happening on our forums, posting is now restricted to verified members only.  If you're not verified, drop us a note with your username.

Home > FlexCMS Support Forum > User Help > General Support Requests > 'NotifyBoards' default value error at after step 4

FlexCMS Support Forum


'NotifyBoards' default value error at after step 4
Started April 6, 2006 @ 5:46am by zappa2
Post Message 
zappa2


Posts: 3
 
'NotifyBoards' default value error at after step 4April 6, 2006 @ 5:46am
Hi,

after step 4 in the installation I receive this error:

"Field 'NotifyBoards' doesn't have a default value"
In the adress bar I see ...flexcms/install.php?5.

When I try to view my site on the url ..../flexcms/index.php I only an index of the files in the flexcms folder. On top of the page I can see my domain name.

The installation seemed not to be finish correctly because of the error after step 4.

Howe can this error be solved?

Thank you,

Jasper
 

Last Edit: April 6, 2006 @ 5:49am by zappa2
DCSun
Administrator



Posts: 625
 
April 6, 2006 @ 9:20am
Hi Jasper,

Sorry to hear you're having problems getting FlexCMS installed.

I've seen that error once or twice before, but it's been very rare so we've not been able to pin down why it's occurring.

One thing you can do to get around it, is to go into the database directly and create a default value for that field (it's in the core-Users table).

If you're still having problems, please let us know and we'll see if we can give you a few other things to try.


Thanks,
David


FlexCMS v3.2 Has Been Released!
 
zappa2


Posts: 3
 
April 6, 2006 @ 10:12am
Hi David,

thank you for your response!
I have found out that the problem is caused by MySQL 5 running in strict mode by default. This mode does not accept empty variables.
I had to go to Start-->MySQL-->Server Config Wizard, followed through the detailed config steps and deselect 'Enable Strict Mode'.

Now I have my site up and running!
One new point: when I choose in the admin panel to Manage/Upload images or when I try to upload an custom image to the front page, I just get a white screen. Seems like imageupload.php crashes or something. How can I solve this?

Thnx

Source MySQl fix:
http://wordpress.org/support/topic/48933

Best Regards,

Jasper
 
DCSun
Administrator



Posts: 625
 
April 6, 2006 @ 6:14pm
Jasper,

Glad you got FlexCMS installed, and thank you for the information about how you got it working. We'll try to modify how FlexCMS functions to get around MySQL 5's strict mode, or provide that information along with it.

As for your other problem, that's an interesting one -- I don't think I've seen that before. First off, create a PHP info page and look to make sure GD is enabled and functioning. If that all looks good, give us some more details about your server (operating system, serving software, PHP and MySQL versions, etc), and we'll see what we can come up with.


David


FlexCMS v3.2 Has Been Released!
 
zappa2


Posts: 3
 
April 7, 2006 @ 3:39am
David,

thnx for your help again!

I checked with php -m what modules were loaded, but not GD. I found out that I had to uncomment "extension=php_gd2.dll" in php.ini. Now it works fine.
Source: http://www.phpfreaks.com/tutorials/105/0.php

But it seems that the new PHP5 (when installed with setup.exe) will give beginners many problems. I also had to manually put in mySQL5 extension support before.

I think I'll just uncomment all extensions in php.ini to prevent more problemsWink

Greetings,

Jasper

 

Last Edit: April 7, 2006 @ 3:43am by zappa2

Post Message 




Try & Buy FeedForAll - Easy to use RSS Feed Creator - great for iTunes users!

MEMBERS




All Contents, Code, Scripts and Technologies Copyright 2003-2009 FlexCMS.
All Rights Reserved. Software License Agreement

Processing Time: 0.07855 seconds.
 
Management Login

Powered By FlexCMS
Powered By FlexCMS