, Guest!
Already a Member? Login or Register.

Menu



Showcase


Due to the volume of spam happening on our forums, posting is now restricted to verified members only.  If you're not verified, drop us a note with your username.

Home > FlexCMS Support Forum > User Help > General Support Requests > Upload image error

FlexCMS Support Forum


Upload image error
Started December 15, 2012 @ 6:33am by Jorge
Post Message 
Jorge


Posts: 15
 
Upload image errorDecember 15, 2012 @ 6:33am
I have a site a several years with the version 2. About one month ago I upgrade to version 3.2.1.
Today start a new job, put old pictures on my site and when try to doit receive the bellow error.

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 17152 bytes) in /home/lmmcom/public_html/inc-pg-admin-photos_upload.php on line 166

I dont have access to php.ini (the site is rented).
How could bypass this?

Thanks
 

Last Edit: December 15, 2012 @ 6:37am by Jorge
DCSun
Administrator



Posts: 625
 
December 15, 2012 @ 11:45am
Hi Jorge,

64MB is a pretty typical limit anyways so I wouldn't worry too much about changing that. For what it's worth in the future, though, some hosts allow you to place a php.ini in your site's directory that will override certain default settings, depending on how they have things set up.

How many photos were you trying to upload at once? How big are they in file size? Do you get the same error when trying to upload the same files to our demo site? (http://www.flexcms3.com/index.php/admin/photos.html - username/password: demo)


David


FlexCMS v3.2 Has Been Released!
 
Jorge


Posts: 15
 
Memory sizeDecember 15, 2012 @ 4:54pm
Hi David

Thanks for fast answer.

The picture it's only one with 3,8 Mb and the setup allow 7Mb (I change this many years ago).
I will go try the "php.ini" on root directory and if solve the problem I tell here.

Thanks.

bty
Jorge
 
Jorge


Posts: 15
 
memory limit (SOLVED) another qstDecember 15, 2012 @ 5:38pm
Hi David,

Case solved, php.ini on root folder.

But have another one. When Upload a pic the thumbnail as permissions 0644 but the original file (full image) is saved with 0640, this disable the world to view the image, where or what need to change to solve this?

bty
Jorge
 

Last Edit: December 15, 2012 @ 5:38pm by Jorge
DCSun
Administrator



Posts: 625
 
December 15, 2012 @ 11:11pm
Jorge,

First would be to have a look in your site's database with PHPMyAdmin or similar if you have it available (if not let me know and I'll give you some other options). Go into the core-Settings table and browse through until you find a row called FilesCHMOD, see what that's currently set at. If that's not where it's setting it to 640, it might be related to the ownership of the script file, or something in your settings on the host side (either through the php.ini or something you'll have to contact them about). If all that fails, let me know and maybe we can add a line into the code that changes the permissions on the files after they're created.

David


FlexCMS v3.2 Has Been Released!
 
Jorge


Posts: 15
 
chmod (Solved)December 16, 2012 @ 3:38pm
Hi David,

Thanks for the tip.

I changed the FilesCHMOD on MySQL from 0640 to 0644 and works.

Thanks

P.S. - Merry Christmas and a god New Year
 
DCSun
Administrator



Posts: 625
 
December 16, 2012 @ 3:47pm
Not a problem, glad you got it sorted out.

Safe and happy holidays to you as well!


David


FlexCMS v3.2 Has Been Released!
 

Post Message 




Try & Buy FeedForAll - Easy to use RSS Feed Creator - great for iTunes users!

MEMBERS




All Contents, Code, Scripts and Technologies Copyright 2003-2009 FlexCMS.
All Rights Reserved. Software License Agreement

Processing Time: 0.06100 seconds.
 
Management Login

Powered By FlexCMS
Powered By FlexCMS