, Guest!
Already a Member? Login or Register.

Menu



Showcase


Due to the volume of spam happening on our forums, posting is now restricted to verified members only.  If you're not verified, drop us a note with your username.

Home > FlexCMS Support Forum > User Help > General Support Requests > Edit blocks - pages partially displayed

FlexCMS Support Forum


Edit blocks - pages partially displayed
Started July 23, 2005 @ 7:49pm by notdodgy
Post Message 
notdodgy


Posts: 46
 
Edit blocks - pages partially displayedJuly 23, 2005 @ 7:49pm
This problem seems to present only for some block editing pages.
The problem only happens for custom blocks when using the Firefox browser.

e.g. when editing the weather and news block, the page "stops" after the "custom block contents".

Work around is to use another browser.

I wondered if it was what was in the contents window itself that was the issue here.

When I do a view source all the page is there, though some lines are very long.
I also saw that some < symbols are substituted with html codes.

Code


e.g. <b>Weather: & l t ; /b>
(& l t ; has added spaces to get it to display in the forum)


A strange one.

Roger
 

Last Edit: July 23, 2005 @ 7:52pm by notdodgy
DCSun
Administrator



Posts: 625
 
July 24, 2005 @ 12:12am
Roger,

That is a strange one for sure.

First off, can I get you to try replacing your inc-core-admin-blocks-edit.php with the one in the update package? Then try correcting it, saving the changes, and going back to edit it the way you did in the first place.

If updating that file doesn't help you, is there a live Flex site where I can see this problem? Also, what version of FireFox are you using?


Thanks,
David


FlexCMS v3.2 Has Been Released!
 
notdodgy


Posts: 46
 
Stranger StillJuly 24, 2005 @ 5:01pm
Hi,

Copied in the file from the update.

Found I could see the whole page, I then set the Block Enabled option to yes and saved it.

Tried re-editing and the problem was back.
I noticed that the content block contains the html for the rest of the edit page. And the left arrows are shown as & l t ;

Changed the setting (in phpmyadmin) back to hidden and I could edit again and the left arrows are shown correctly.

This only affects this one block edit page - e.g. the login page works fine.

So why are left arrows being converted to & l t ; when the block is enabled?

I am using Firefox/1.0.4. So will try a newer version.
Email me for direct access to the website.

Roger
 
DCSun
Administrator



Posts: 625
 
July 24, 2005 @ 7:40pm
Roger,

Thanks for the update. If upgrading your version of FireFox doesn't solve it, please email the information for the site to and we'll take a closer look for you.


David


FlexCMS v3.2 Has Been Released!
 

Last Edit: July 25, 2005 @ 12:36am by DCSun
DCSun
Administrator



Posts: 625
 
July 25, 2005 @ 2:08pm
The changing of '<' into '& lt;' was done by FlexCMS and is the desired behavior. This was done so that any code can be used in the text area and it won't cause problems. For example, if you had '</textarea>' in your code, without changing them that would end the text area on the editing page and cause all sorts of problems (kind of like what's happening now!).

I've modified the FlexCMS code for that section, and it seems to be working fine on both IE and FireFox now. You can download the updated file here: http://www.flexcms.com/downloads/in...re-admin-blocks-edit_25july2005.zip


Thanks,
David


FlexCMS v3.2 Has Been Released!
 

Last Edit: July 25, 2005 @ 2:10pm by DCSun

Post Message 




Try & Buy FeedForAll - Easy to use RSS Feed Creator - great for iTunes users!

MEMBERS




All Contents, Code, Scripts and Technologies Copyright 2003-2009 FlexCMS.
All Rights Reserved. Software License Agreement

Processing Time: 0.07717 seconds.
 
Management Login

Powered By FlexCMS
Powered By FlexCMS